I tried so many times and I found that is a preference file that causes this:


I just created a blank text file on the desktop and remane it as “com.apple.logic.pro.cs” , and replace the original one in Library. Then I locked the file.(click the file, command+I, there’s an option to lock it). Problem solved!

Although now everytime I open Logic it shows “File “com.apple.logic.pro.cs” is not a Logic Pro X Preferences File!”, I wouldn’t mind it because I can use this bluetooth connection again!

Sorry for my bad English. Again, I’m using a different brand’s bluetooth keys and I can’t guarantee this solution will help your situation. But I really hope it helps! Cheers.