Tagged: 

Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
    Posts
  • #30936
    electricarts
    Participant

    My Xkey 37 Air can be connected via Mac OS X Audio Midi Setup (Bluetooth) and works in Logic Pro. But only as long as Logic is open. When I close Logic a few minutes later the blue LED flashes and I have to open Audio Midi Setup again and reconnect the Xkey. This also happens if Logic Pro is not opened after connecting the Xkey in Audio Midi Setup.

    Is this a normal behaviour? I have assumed that the Xkey Air will behave like other BT input devices. I connected them once and they stay connected until I manually remove them. Whether I close a program or not.

    #30937
    Zhao Yitian
    Keymaster

    Not sure where did the problem come from, this sounds not normal, maybe you can try below things:
    1. Upgrade both USB and Bluetooth firmware of Xkey Air 37 by using our Xkey Plus free software. You can download it from our website.
    2. Do “reset to factory” in the Xkey Plus software.
    3. Set the battery saving mode to “never”.
    null

    • This reply was modified 5 months, 3 weeks ago by Zhao Yitian.
    #30944
    electricarts
    Participant

    Hey, Zhao,

    thanks for your reply!

    I’ve done all these things before. I do not know where to look or what else to test.

    I have one more idea. I connect the Xkey to a virtual machine (VMware Fusion) to see if it is a Mac OS X problem.

    #30945
    electricarts
    Participant

    I’m a bit confused. Didn’t you say that this is not normal behaviour? But here in this

    Thread

    this is exactly what is described and you answered that this is normal.

    #30946
    Zhao Yitian
    Keymaster

    Once you connect the Bluetooth MIDI in Audio MIDI setup, it should keep connecting whatever you open the Logic Pro or not (unless you are in battery saving mode, the Xkey will switch to sleep mode every few minutes if you do not play it). The behaiour you linked said everytime you wakeup the computer, you should connect Bluetooth MIDI manually again, that is normal. I thought it was different than your situation.

    #30947
    electricarts
    Participant

    Oh sorry, you’re right. It’s not exactly my problem.

    I tested a little further. Exactly 5 minutes after closing a program (Logic or Garageband or Audio Midi Setup) the Xkey loses its BT connectivity.
    It is not triggered by inactivity. For example, I can open Audio Midi Setup for hours without activity and Xkey stays connected. But if I close Audio Midi Setup, the Xkey will disconnect after 5 minutes exactly. So it’s some setting ( Mac OS X or Xkey ) that triggers the automatic shutdown when not in use.

    #30948
    Zhao Yitian
    Keymaster

    If you already set the baterry saving mode to “off” on Xkey Air, maybe there is some setting about your computer Bluetooth in dormant mode?

    #30949
    electricarts
    Participant

    I just connected the Xkey to another Mac (macOS 10.14.6) and the behaviour is the same. After exactly 5 minutes of inactivity it loses its connectivity. So I don’t think it is a macOS X setting.

    Is there any kind of “factory reset” outside the Xkey Plus app?

    #30950
    Zhao Yitian
    Keymaster

    You can hold Oct+/- at the same time and switch on the keyboard, it will do factory reset too. Are you sure you set the battery saving mode to off already?

    #30951
    electricarts
    Participant

    I did, but it did not change anything. Yes, the battery saving mode is off.

    But in the default setting it is already set to 15 minutes. The Xkey should stay connected for at least 15 minutes in the default setting and not lose the connection after 5 minutes.

    #30952
    Zhao Yitian
    Keymaster

    Then I have no idea… :`(

    #30953
    electricarts
    Participant

    All I want to know is whether the problem is known at CME or not. Or if any other Xkey Air user had or has this problem. I tried all settings including factory reset and connected it on another Mac (macOS Mojave).

    CME definitely cannot reproduce this problem?

    #30954
    Zhao Yitian
    Keymaster

    We reproduced this issue on one Mac with Catalina. To compare, if we use WIDI BUD, it has no problem. We will investigate and try to find out where did the issue come from.

    • This reply was modified 5 months, 3 weeks ago by Zhao Yitian.
    #30956
    electricarts
    Participant

    Thanks for your commitment and care!

    The Widi Bud is great, but that would mean another 60 € in expenses for me. ;-(

    • This reply was modified 5 months, 3 weeks ago by electricarts.
    • This reply was modified 5 months, 3 weeks ago by electricarts.
    #31019
    Zhao Yitian
    Keymaster

    We still cannot find the solution for this, it seems Apple Mac OS has some limitation for Bluetooth MIDI connection. We will try to check with Apple and see if they have any solution for us.

Viewing 15 posts - 1 through 15 (of 17 total)
  • You must be logged in to reply to this topic.