Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #28683
    qryss
    Participant

    I believe this is a known problem. It is discussed elsewhere (the Audiobus forum and the Auria forum at least) as having been raised with CME but no solution has yet been found.

    Briefly, certain interactions within Auria Pro (e.g. tapping any of the playback controls) will immediately and consistently disconnect the Xkey Air.

    I have some specific details to report that *may* help debug this issue.

    I have been using an Xkey with version 2.3 (?) firmware (and Bluetooth firmware 1.1(?)) and the behaviour was the following:

    – tapping (e.g.) rewind results in the XKey’s blue light starting to flash

    – going into Auria Pro setting to re-connect showed the iOS message ‘not connected’

    After upgrading to the latest firmware (2.4) and Bluetooth 1.4 the behaviour is different:

    – tapping rewind causes *no* change in the blue light: it remains constant

    – going into Auria Pro settings to re-connect shows the message ‘offline’

    I hope that difference helps point to what is going on. It certainly is peculiar behaviour and is very specific to Auria Pro – most other software does not cause a disconnect (I have found one other case but I’ll report that separately).

    #28691
    jerome
    Keymaster

    Hi
    Could you please let me know how do you connect to the computer ? Through WidiBud or natively ?
    Does this issue appear only with realtime MIDI messages ?
    Also, what computer/OS version do you use ?
    Thanks
    Jerome

    #28697
    qryss
    Participant

    Hi Jerome,

    I am not using WidiBud. I have tried using both MidiMittr and also the Bluetooth connection dialog in Auria Pro’s Settings panel (I presume that exposes the native iOS Bluetooth MIDI setup).

    I’m using an iPad Air 2 and the latest iOS version (11.2.6). Also latest Auria Pro (2.16).

    I’ve not done exhaustive tests of which controls in Auria Pro cause this but I can tell you some of them that consistently do it:

    – record enable
    – double tap on rewind (but not a single tap on this or on fast forward. I misunderstood this before)
    – stop (but not play)

    I am not aware of any other ‘taps’ that cause the problem. Unfortunately the ones that do are pretty crucial to normal operation!

    Let me know if you need more information.

    • This reply was modified 4 years, 3 months ago by qryss. Reason: Minor text changes
    #28703
    Zhao Yitian
    Keymaster

    Hi qryss, I remembered that we solved this problem before:
    It seems the problem casued by MIDI LOOP. Please check attached screen shot and deselect “Send Notes” from MIDI Outputs.
    Auria MIDI setup

    • This reply was modified 4 years, 3 months ago by Zhao Yitian.
    #28707
    qryss
    Participant

    Awesome. That does indeed fix the issue.

    Thank you so much!

    qryss

    #28708
    Zhao Yitian
    Keymaster

    Hi qryss, great! Enjoy your Xkey Air. 🙂

    #28721
    mkountz741
    Participant

    I know this discussion is regarding Aria Pro but I am having the same problem in Beatmaker 3. When hit stop or record I lose connection with my Xkey. When I go to reconnect it says “offline”.

    #28722
    Zhao Yitian
    Keymaster

    Please check your Beat Maker 3, if the Xkey Air was shown in MIDI OUTPUT device list, please unselect it, so that it will not cause MIDI LOOP issue.

    #28948
    katapulttom
    Participant

    Hallo. I Have the same Problem with Auria Pro, loosing bloototh Connection. Can‘t find the attached screen Shot to solve the Problem. Please help. Greetings, tom

    #28949
    Zhao Yitian
    Keymaster
Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.