• This topic has 27 replies, 7 voices, and was last updated 8 months ago by pod.
Viewing 15 posts - 1 through 15 (of 27 total)
  • Author
    Posts
  • #28765
    JS
    Participant

    I have shown time and time again (in my livestreams) that MIDI devices do not work right without a driver. Todays livestream I demonstrate that using my current cocktail of DAWs the xkey disconnects recurringly from 52:30 thru the end, at least 10 times: https://youtu.be/GUImADMRBe4
    So that not only do Xkey air NOT connect via Windows BLE, (and I’m not going to buy a Widibud when my Yamaha’s BT01 transmits fine, and windows can see Xkey but not connect just as Xkey attempts fail over android where I recieve the message “bad private key”) but also now barely hold a basic Class Compliant MIDI channel. By the way class compliant means BARE MINIMUM. This should work via BLE as Windows can see and attempt to pair with xkey but fails with yellow refusal/retry message.

    The simple fact with MIDI is that every device needs a driver. Otherwise the MIDI will be blocked by the first program it is run thru, from running to any and all other programs. I have a current config using 5-6 MIDI keyboards simultaneously and I can recommend that you try to fashion a driver like the one for the M Audio which I use (have installed) two, the ‘Legacy keyboard’ and the ‘Oxygen 8’. They have never failed to put the device, with the same name every day, into every program I open concurrently. The Oxygen 8 v2 is an exceptional MIDI device because it has a driver.

    Very frustrating, How can you not know this? How do you not have a driver? This is the reason the Xkey won’t stay connected and the reason it can only be seen by the first DAW or synth opened.

    • This topic was modified 2 years, 1 month ago by JS. Reason: added tags, clarification of first paragraph
    #28767
    jerome
    Keymaster

    Hi
    I checked your video, and you explain in the description the Xkey disconnected due to a USB cable issue.
    I do not think your problem comes from a missing driver.
    Class compliant USB devices just work fine without driver, that is the purpose of class compliant drivers.
    About 90% of MIDI USB devices manufacturer do not provide any driver.
    We sold several thousands of units, and nobody complains about a missing driver.
    If you face disconnection issues, you have to check if your USB cable is correct, or, if you are connected through a USB hub, any problem that could come from this hub, or any other hardware issue around USB.
    Regarding the device blocked by the first software it connects to, yes, this is specific to windows which is not multi-client, OSX is multi-client, not window, unfortunately, are you running on Windows ?
    I’ll check on Internet if there are multi-client generic MIDI drivers for Windows, that may solve the issue you mentioned.
    Regards
    Jerome
    CTO @ CME

    #28769
    JS
    Participant

    I shouldn’t even have to use a USB hub. !!! It’s an Xkey air connecting to windows Version 1703, where BLE was capable on Windows 16– series versions. which arrived in late 2016. Mine was updated last in the late Summer of 2017. And the Bluetooth Low Energy (BLE) works with the Yamaha MD BT01. So Touche your comments about me being a dip who is having problems with his USB. Which I don’t appreciate, I know you’re trying to keep the flames away from the temple. But the only way to do so is to correct the problem with the Bluetooth. Everyone knows it, and no one oughtta have to burn a USB hub about this.

    And I am looking into making a driver, since you make it clear that your company is choosing the low road here as far as drivers go.

    #28770
    JS
    Participant

    Seriously. This needs a driver BAAAD. I KNOW there’s no one out there who can use this seriously with windows. It disconnects from Studio One after 1 minute, the second I play an aftertouch note. It disconnects similarly from Live Professor II. The only thing that holds this is a desktop CS80 synth from Arturia. However that at least proves that it can be held and is not the fault of my USB connection. The MidiBerry program which is the easiest way to get it back online again by disconnecting reconnecting with a quit of the MidiBerry and restart, and reselecting of the MIDI device and Loop out, is not able to hold this thing for long.

    So therefore RECORDING of the Midi in is impossible with Studio One. Especially the aftertouch. Studio One freezes up too, when MIDI devices are removed and added on USB ports, so that’s not even an option.

    This is worthless device without a driver. Windows users for sure should be advised NOT to purchase this device.

    Too bad this will be worthless forever without a driver.

    #28771
    jerome
    Keymaster

    Hi
    From what I understand, you have two issues, one being the USB MIDI connection which is not multi-client, the second being the native connection with BLE MIDI on windows, right ?
    For the multi-client issue, developing a USB MIDI driver is not in our plans.
    Regarding your second issue, I’ll check the native BLE MIDI connection with Windows.
    If you could be less aggressive, that would be nice, thanks.
    Jerome

    #28773
    jerome
    Keymaster

    Hi,
    Could you please contact me at [email protected] ?
    I’ve a beta firmware that should connect natively to windows 10 BLE MIDI.
    I need to provide you the instructions to install this beta firmware.
    Thanks
    Jerome

    #28774
    JS
    Participant

    I am still attempting to get this thing to work properly. I also experience the problems that the guy with the Apple in your other forum posts described. It seems to shut off the USB port, and the port must be switched in order to work. I have doene some further sploration into the use of Higher LoopMidi signals/time before it will trigger the LoopMidi feedback detection. Although the LoopMidi reset from 35000 to 20000 after the Blue Screen Of Death which I believe was triggered when I ran the CME XKey on the same USB Hub as the interface. Either way, there were problems. With a 512 buffer size and the 35000 signal / 5 second ration it hung out a bit longer.

    A driver will be necessary to get it to work without LoopMidi. Only way. With a driver it can be distributed as you said to “multi-client” ie many synth programs and daws at the same time. Thus LoopMidi can be denecessitated in the scenario.

    Whether the Aftertouch will ever be recordable in Studio One is a whole different problem. Obviously the Studio One and some other DAWS handle this input different. If you search for aftertouch recording on the internet the Studio One is not reported to do this. It is reported that it works in some DAW. Don’t know and don’t have that DAW.

    A driver will be necessary for this device. Meanwhile I have went in the XKEY program and dialed down the aftertouch to half the period and sensitivity. Not much else I can do without making a driver. When did you come up with the Beta Firmware? Why not put that out here for everyone to test? I am sure that people would like to download that one. I will take it, please send it to my account address.

    #28775
    JS
    Participant

    Here is a list of problems the Xkey Air is throwing up in my situation.

    Inside the daw, it will shut off and stop recieving signal from the xkey air MIDI device
    It will be unavailable in the DAW from the moment that the DAW is started, and has proven to NOT be Reattatchable without ALL of the following:
    Unplug and plug into a different USB port
    restart the Xkey (especially in the case where it has shut off)
    CLOSE any additional MIDI receiving programs (with the exception of LoopMidi which runs all the time)
    THEN restart the DAW
    reassign the track to the MIDI input

    Now it will show up again for between 15 seconds all the way up to a few minutes.

    I heard there was a guy on these boards who bought 6 of these things and was trying to run them in Windows…
    sorry but I had to laugh thinking about that guy, tryin to run 6 of these Hydrogen powered beasts into Windows.

    This device doesn’t work. Plain and simple.

    Let me give you a scenario.

    You open Studio One (as I have just in the last 30 minutes)
    You run Xkey into a midi and watch the Yellow meter rising and falling with the inputted signals.
    You drop the instrument “Analog Lab” from Arturia on the track and set the instrument to Nazgul preset
    Before you can even play A NOTE, the Xkey has become disconnected.
    I must be asking too much to expect a WHOLE DAW to open and run an instrument track with this thing.

    Nightmare device. Would take a driver, or money back but I refuse to waste my time even turning this thing on from now on.

    #28776
    JS
    Participant

    I removed the USB 2.0 x 7 hub (cheap USB hub) from my equation and that solved the problem of the disconnects. Seems to be solved 100 percent. Also I increased the LoopMidi value for “Detects feedback from” to 20000 commands per 3 seconds and the Sysex Buffer to 512 KB. I had changed the Xkey Plus settings to Aftertouch Noise Floor = 8 (from 4, now changed back) and Aftertouch Period = 50 ms (now reverted to original 16).
    The USB was disconnecting all the time before I switched to my current USB device.
    If you are having disconnections it SEEMS likely it is your USB device.

    When the Bluetooth firmware is available through the XKey Program? Eager to try it through bluetooth and cut out USB problems altogether. Whats the word on Beta testing of this firmware?

    A Driver is still needed, if only for people who wanna make Xkey Plus changes on the fly in the claimed supported Windows platform. I’m surprized you maintain your Bluetooth SIG status allowing the huge Bluetooth brand on the device with the device not operating in Windows: https://www.bluetooth.com/develop-with-bluetooth/marketing-branding/brand-enforcement-program.

    Like I said a Really GOOD driver would take the bluetooth signal and run it through a Windows API which could deliver it with its XKEY AIR 37 (or 25) name to ANY AND ALL program which take MIDI. Silently and with no stress for the user. Yamaha’s driver is good at this, with only Rare NAME CHANGES due to some programs like Ableton Live Lite and LMMS M Audio Legacy Keyboard Driver and Oxygen 8 driver (running at the same time on my system, always) are even better, with NO name change EVER.

    As Apparently the ONLY person currently existing who has the experience to talk about MIDI driver value in windows I would make a checklist similar to the one at the Bluetooth.com website, but for the driver:
    – Take the BLE signal (with all aftertouch at top sensitivity)
    – Route it (via Windows Bluetooth API where necessary) to any and all open .exe programs which take MIDI devices

    #28777
    jerome
    Keymaster

    Hi
    I suggested you that you check if a USB hub is causing your issue, your answer was :

    “I shouldn’t even have to use a USB hub. !!! …. So Touche your comments about me being a dip who is having problems with his USB. Which I don’t appreciate, I know you’re trying to keep the flames away from the temple. But the only way to do so is to correct the problem with the Bluetooth. Everyone knows it, and no one oughtta have to burn a USB hub about this.”.

    >> No comment.

    Regarding the beta firmware that should connect to Win 10, please install this Xkey Plus version :
    https://www.dropbox.com/s/rtleirkh4ibdroj/XkeyPlusV26BetaFw.zip?dl=0 (win version)

    This version allows to burn beta firmware.
    Open the soft, click bluetooth panel once your Xkey is detected, then check for bluetooth firmware, you should see the latest beta version 1.5

    Once upgraded, switch off-on your unit, and connect to win 10 through bluetooth.
    Let me know if this new firmware solves your issue.
    Jerome

    #28779
    jerome
    Keymaster

    Hi JS
    Any news about the native connection to win 10 ?
    Thanks

    #28784
    JamesJ01
    Participant

    JEROME!!!!!!!

    YES YES YES….I am connected, over bluetooth, to my windows 10 machine…WITHOUT THE WIDIBUD!!! (though it only works with UWP apps)

    You see…this was a big frustration for me…and I see the exchange above with the OP got a little tense…I was frustrated too, but I’m here to say thanks though, because I am REALLY glad this software now exists, even if just beta and not multi-client.

    I have a Dell tablet with only 1 USB port and 1 USB C port. A big part of why I bought the xkey37 air was to save using a USB port…sure I could use a hub, but the whole idea was to be wire free…my mouse and typing keyboard are also bluetooth.

    I went ahead and bought the WIDIBUD, but at that point I felt like I should have just bought the wired xkey.

    This is great…when Windows finally updated their bluetooth to include the BLE stuff I was excited, and then disappointed that the xkey still didn’t work.

    We still have the issue on android though…but I realize that’s the responsibility of the music app devs…there is ONE app on the google play store that’s basically a BLE test app…with that I can connect my xkey air over bluetooth to my samsung android tablet…and it works…the problem is any of the real music apps for Android – FL Studio Mobile, Caustic, G-Stomper…they still don’t recognize the xkey air…even though they claim to work with BLE…But that one test app proves that it’s possible. I realize that’s not something you guys can fix. And it’s frustrating because THAT tablet only has the one port, which I need to use for charging, so I can’t use an OTG adaptor with the WIDIBUD if I want to be sure the tablet stays powered up during a live performance.

    And as for multi-client…I know it’s not coming…but one trick I do is connect the xkey air with a USB cable AND connect the WIDIBUD…then I can use the xkey (over USB) in one DAW, and the WIDIBID in another DAW…that at least gives me 2 apps at once..and I’m pretty sure MIDI-ox or something like that can turn the one actual device into several virtual devices that can all be used in various DAWS simultaneously. Haven’t tried.

    Thanks again for this beta …I’ts working well with FL Studio Mobile on windows, which is a UWP app, and it reconnects if I power the Xkey down and back up.

    It does NOT work with Reaper…but that is to be expected as it’s not a UWP app and Reaper doesn’t include support for BLE. ANd perhaps that’s the “Driver” we’d really like to see…

    Perhaps it needs to exist as a UWP app that recognizes the xkey over BLE…and “streams” that incoming midi to a virtual midi device within the Windows native environment…But as stated by the OP, other brands have made their BLE MIDI devices compatible with “Desktop” windows programs. Frankly, those are the ones most musicians are using…FL Studio (non mobile version), Pro Tools, Reaper, Ableton Live, etc etc.

    In other words it would show up as a MIDI device in any Windows DAW…not just UWP apps (like FL Studio Mobile) but 32 and 64 bit windows desktop apps.

    But this bets is a great step, at least windows is now recognizing the Xkey and it works with FL Studio Mobile.

    #28794
    Lorrence
    Participant

    It’s not the USB hub that was causing my main issues. It turned out to be that I was sending something like 8000 aftertouch messages through loopMidi in less than 5 seconds and it was triggering the loopMidi feedback detection default of 5000 aftertouch messages in 5 seconds. So I turned down the sensitivity, and I set the loopMidi default up to 20000 messages in 3 seconds.
    It also seems that it doesn’t work well in cheap usb ports. Because I also had that as an issue with a very cheap 2.0 USB hub. It worked fine in the very cheap USB 3.0 hub so far though, from the same company.

    I haven’t tried this driver yet. the new Xkey plus but it’s on my to do list.
    I now have two computer configuration so the bluetooth being used a 2nd time simultaneous to the wired computer, on the new computer is on my try to do list.

    #28795
    Lorrence
    Participant

    Ok. I tried it. It did an automatic update of the firmware. I still couldn’t connect via bluetooth. I then recieved a notification from my traffic monitor that it has 1 malware, the W32.eHeur.Malware09.
    The file itself has a compilation timestamp from 2016-10-03 07:32:18.
    it is easily unzipped.
    I see JS is listed as the keymaster here. But to no avail. This still doesn’t work on my windows bluetooth LE. Maybe it will work after a restart but I highly doubt it. I am running the version of windows 1703, which I have vigilantly defended from update, and which would have been the active version at the time of this compilation.
    I don’t understand why the 2.6 firmware is not downloaded by the original xkey program, which claims to search for firmware online.
    End result: negative.
    I went ahead and reinstalled the 2.4 firmware from my second computer which also has the xkey plus original. Doesn’t make much difference I guess. It’s still a pretty good keyboard for aftertouch.
    Interesting to note that Windows app MidiBerry now is minimizable as I get the new system online and update apps which had not been updated in a long time.

    • This reply was modified 1 year, 11 months ago by Lorrence.
    #28797
    Lorrence
    Participant

    The cme-pro.com domain which downloads the 900kb parcel at the time of the first execution of the portable exe file has an extensive dns information listing with dnslytics.com. Not saying much about it, but the ip hosts 183 domains currently, at least one of which is an adult content domain. It includes such domains as cme-pro.com, luckyniki.dk, darktracemedia.ca, amigosmexicantakeaway.co.uk etc etc.
    The only takeaway from this firmware is it don’t enable bluetooth. And on second try, didn’t do any thing automatic, and wouldn’t update a firmware to 2.6 or anything like that.
    The current firmware stands at 2.4 \what is this download, created in 2016, and not officially run via the original xkey, even for?

Viewing 15 posts - 1 through 15 (of 27 total)
  • You must be logged in to reply to this topic.