Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #28630
    titifunk
    Member

    Hello,

    I can’t use the keyboard with Logic Pro. I connect the keyboard with the bluetooth utility and when i open logic Pro it says 1 In/ 1 Out and immediately 0 In/0 Out and key stop to work with the application.
    It’s weird because it works perfectly with Garage Band or Reason. I have a Mac Book Pro Retina.
    Does anybody know how to solve this problem.
    Thank u.

    #28652
    Zhao Yitian
    Keymaster

    Dear Titifunk,
    Sorry for replay late, just came back from NAMM show.
    We tested with Logic Pro 10.3.0 and did not find any problem. So no idea about what was wrong.
    Anyway, please try to make sure your Xkey Air was paired and the Blue LED keep lighting, then open the Logic again.

    Mac OS:
    Turn on Bluetooth.
    Open Audio MIDI setup native application (Applications/Utilities/Audio MIDI Setup.app)
    When MIDI studio is shown, double click on Bluetooth icon.
    Click the Xkey Air you want to connect to.
    The connected Xkey Air will appear as a MIDI device in all applications that respond to MIDI.

    #28666
    titifunk
    Member

    Hello,
    Thank you for your answer.
    I tried many times but it doesn’t work with logic (even with the 10.4 version). In the same time, it works perfectly with Garage Band and Reason. I Tried on another mac book pro (the new version) and it worked also.
    Is there a way to use it with mere USB just to be able to use it with logic also.
    Thank you.

    #28699
    qryss
    Member

    Hi titifunk,

    I’ve just tried this (Xkey Air and Logic Pro X 10.4.1) and it works perfectly.

    Are you using the Audio MIDI Setup utility to connect natively to your Mac?

    Chris

    #28702
    Zhao Yitian
    Keymaster

    Thanks qryss for your support!

    #28785
    amosdeane
    Member

    I also have this problem. Am running Logic 10.2.4 on Mac OS 10.12
    Computer is: MacBookAir6,2

    I regularly have to re-add via Audio Midi Setup. It seems to work ok whilst the song is not running but when I run the song it disconnects. It also works ok with other applications.

    #28786
    Zhao Yitian
    Keymaster

    Hi Amosdeane,
    Could you please check whether you can see your Xkey name on MIDI OUTPUT list in Logic? If yes, please deselect it to avoid MIDI LOOP problem. Also please try to update the firmware for both USB and Bluetooth part by using Xkey Plus software and do “reset to factory”. Hope this helps.

    #28815
    Radim
    Member

    Hi,
    I have same trouble, xkey air connection working with for example Garage band, With xkey piano, but when I am start Logic pro X its made disconection.. I try many times find where is trouble but realy dont know..
    Can someone help?
    R

    #28866
    jerome
    Keymaster

    Please check if that helps :
    https://discussions.apple.com/thread/3818211

    #30824

    I have the same issue. And every time I fix it, it lasts for a few weeks, then it starts happening again.

    All firmwares are up to date.

    All logic input settings are set to mirror system settings.

    Logic is up to date.

    Xkey battery is fully charged.

    Xkey is connected natively through Audio Midi Setup bluetooth connection.

    Xkey bluetooth connection works perfectly with all other apps.

    All other apps except Logic are closed when i try to use the Xkey.

    Xkey works fine over wired USB connection.

    Was working perfectly last 2 weeks, on bluetooth, since the last time this happened and i fixed it by setting the input and output to “system settings” in Logic. No settings were changed, but now, the keyboard gets booted as soon as I open logic.

    If I turn off the Xkey input port in Logic, then the keyboard stays connected via bluetooth, it just can’t be played in Logic.

    I’m about to throw this thing out of the window.

    I hate this.

    Please help.

    #30861
    Zhao Yitian
    Keymaster

    Really no idea since we cannot reproduce your issue here.
    Did you try follow this: https://discussions.apple.com/thread/3818211
    Maybe you could try to pair Bluetooth MIDI after you open the Logic?

    #30907
    ligundd
    Member

    hey cellomusicnow,and everyone who encountered the same problem,

    I am not a Xkey user but I use a similar bluetooth midi keyboard device of KORG.Same thing happened to me. Everything eles is fine, but when running Logic, Bang, disconnected.

    I just deleted all the caches of Logic in the Library. I’m not sure which one(s) is the one I really need to deal with ,so I deleted all of them (didn’t delete the downloaded sound resources).

    I use this application called App uninstaller to delete these caches, it’s more convenient than do it by myself. After deletions my keys runs normally in Logic again!

    It’s not an ad for Korg or this app, I just know how frustraed it feels that this thing you bought for convenience now becomes the most inconvenient sh– lol.

    Hope it helps man!

    #30908
    ligundd
    Member

    I tried so many times and I found that is a preference file that causes this:

    Library/Preferences/com.apple.logic.pro.cs

    I just created a blank text file on the desktop and remane it as “com.apple.logic.pro.cs” , and replace the original one in Library. Then I locked the file.(click the file, command+I, there’s an option to lock it). Problem solved!

    Although now everytime I open Logic it shows “File “com.apple.logic.pro.cs” is not a Logic Pro X Preferences File!”, I wouldn’t mind it because I can use this bluetooth connection again!

    Sorry for my bad English. Again, I’m using a different brand’s bluetooth keys and I can’t guarantee this solution will help your situation. But I really hope it helps! Cheers.

    #30913
    ligundd
    Member

    If you don’t know how to find that file, try open Logic first, then connect your device. The moment you click the connect button, hit any notes in your keyboard as fast as you can. Sounds studpid but it really sovled my problem.

    #30914
    Zhao Yitian
    Keymaster

    Thanks Ligundd!

Viewing 15 posts - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.